summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2017-07-08 20:14:28 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2017-07-08 20:14:32 +0100
commit286194bf8211db68991be7831e76829c7147829a (patch)
tree610274f4b2cdc45b279e5c1ab36d64d6d84065bc
parentd49ec0833c03e428cc5a807331b389f1a70cab74 (diff)
dgit: tolerate compressor terminating with SIGPIPE.
Closes:#857694. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index f25c5d4..91bb617 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,6 +8,8 @@ dgit (3.11~) unstable; urgency=medium
tree. Closes:#865863.
* dgit: rpush: Honour local git config from build host working
tree.
+ * dgit: tolerate compressor terminating with SIGPIPE.
+ Closes:#857694.
* infrastructure: Cope with new git-receive-pack which has
quarantine feature: ie, work around #867702.
* test suite: Cope with git restricting ext:: protocols.
diff --git a/dgit b/dgit
index 6f98813..edb2428 100755
--- a/dgit
+++ b/dgit
@@ -2208,7 +2208,7 @@ sub generate_commits_from_dsc () {
!$? or failedcmd @tarcmd;
close $input or
- (@compr_cmd ? failedcmd @compr_cmd
+ (@compr_cmd ? ($?==SIGPIPE || failedcmd @compr_cmd)
: die $!);
# finally, we have the results in "tarball", but maybe
# with the wrong permissions