summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-29 13:02:36 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-29 13:02:37 +0100
commit3ae4d20d8146c3ea111b3f622bf00adbd4e6442f (patch)
tree836067c453d6d8c5a699e077cb81f23646e0b4b5
parent96f0ac573b0c0672dbeae9ab3d3ace947c7def28 (diff)
test suite: gpg-agent workaround: Cope if ps not found.debian/5.5+exp6archive/debian/5.5+exp6
Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog6
-rwxr-xr-xtests/tstunt/gpg-withagent2
2 files changed, 7 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index a0fea92..8076ac0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+dgit (5.5+exp6) experimental; urgency=medium
+
+ * test suite: gpg-agent workaround: Cope if ps not found.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 29 Jun 2018 13:02:30 +0100
+
dgit (5.5+exp5) experimental; urgency=medium
* test suite: gpg-agent workaround: Add more debugging output.
diff --git a/tests/tstunt/gpg-withagent b/tests/tstunt/gpg-withagent
index 4318cce..3f56d08 100755
--- a/tests/tstunt/gpg-withagent
+++ b/tests/tstunt/gpg-withagent
@@ -3,7 +3,7 @@ set -ex
d () {
date --iso-8601=ns >&2
- ps -ef | grep gpg-agent >&2
+ ps -ef | grep gpg-agent ||: >&2
}
d