summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2015-08-18 16:18:09 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2015-08-18 16:18:09 +0100
commit4c172c32b16c321359d4e17b3f3dd874daee4e91 (patch)
tree4300ddba9c751d81b4acc9f4ef8045c4d50f035c
parent3d241c37fc1139f8942299323d72fc2e493f036c (diff)
When quilt linearisation fails, print the right information in the error message. (This has been broken forever.)
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index cd360c6..9f4ca75 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,8 @@ dgit (1.4~~) UNRELEASED; urgency=low
filenames (which git-add treats as glob patterns).
* When running git-add in commit-quilty-patch, use -f and sometimes -A,
so as to avoid being broken by any .gitignore, etc.
+ * When quilt linearisation fails, print the right information in
+ the error message. (This has been broken forever.)
--
diff --git a/dgit b/dgit
index 916177c..7c76a6f 100755
--- a/dgit
+++ b/dgit
@@ -2627,7 +2627,7 @@ sub quiltify ($$) {
my $abbrev = sub {
my $x = $_[0]{Commit};
$x =~ s/(.*?[0-9a-z]{8})[0-9a-z]*$/$1/;
- return $;
+ return $x;
};
my $reportnot = sub {
my ($notp) = @_;