summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2017-08-24 15:41:49 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-16 12:25:49 +0100
commit54a18d290527b6aa515592d27f90f35187757e8c (patch)
tree7be045f6fc44ce1480943e539bbaedb13c7731d8
parent3e9cb86bb654846019aedc74db306934aabb4f93 (diff)
Dgit.pm: Move $playground global to dgit.
It makes the interface to the playground functions confusing. No functional change. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--Debian/Dgit.pm22
-rw-r--r--debian/changelog3
-rwxr-xr-xdgit3
3 files changed, 13 insertions, 15 deletions
diff --git a/Debian/Dgit.pm b/Debian/Dgit.pm
index c4a61af..f299450 100644
--- a/Debian/Dgit.pm
+++ b/Debian/Dgit.pm
@@ -65,7 +65,7 @@ BEGIN {
%EXPORT_TAGS = ( policyflags => [qw(NOFFCHECK FRESHREPO NOCOMMITCHECK)],
playground => [qw(record_maindir $maindir $local_git_cfg
$maindir_gitdir $maindir_gitcommon
- fresh_playground $playground
+ fresh_playground
ensure_a_playground)]);
@EXPORT_OK = ( @{ $EXPORT_TAGS{policyflags} },
@{ $EXPORT_TAGS{playground} } );
@@ -465,7 +465,7 @@ sub git_slurp_config_src ($) {
# terminology:
#
# $maindir user's git working tree
-# $playground area in .git/ where we can make files, unpack, etc. etc.
+# playground area in .git/ where we can make files, unpack, etc. etc.
# playtree git working tree sharing object store with the user's
# inside playground, or identical to it
#
@@ -485,28 +485,26 @@ sub git_slurp_config_src ($) {
#
# fresh_playground SUBDIR_PATH_COMPONENTS
# e.g fresh_playground 'dgit/unpack' ('.git/' is implied)
-# default SUBDIR_PATH_COMPONENTS is $playground_subdir
+# default SUBDIR_PATH_COMPONENTS is playground_subdir
# calls record_maindir
# sets up a new playground (destroying any old one)
-# assigns to $playground and returns the same pathname
+# returns playground pathname
# caller may call multiple times with different subdir paths
-# createing different playgrounds; but $playground global can
-# refer only to one, obv.
+# createing different playgrounds
#
# ensure_a_playground SUBDIR_PATH_COMPONENTS
# like fresh_playground except:
# merely ensures the directory exists; does not delete an existing one
-# never sets global $playground
#
# then can use
#
-# changedir $playground
+# changedir playground
# changedir $maindir
#
# playtree_setup $local_git_cfg
-# # ^ call in some (perhaps trivial) subdir of $playground
+# # ^ call in some (perhaps trivial) subdir of playground
#
-# rmtree $playground
+# rmtree playground
# ----- maindir -----
@@ -538,8 +536,6 @@ sub record_maindir () {
# ----- playgrounds -----
-our $playground;
-
sub ensure_a_playground_parent ($) {
my ($spc) = @_;
record_maindir();
@@ -562,7 +558,7 @@ sub fresh_playground ($) {
$spc = ensure_a_playground_parent $spc;
rmtree $spc;
mkdir $spc or fail "failed to mkdir the playground $spc: $!";
- return $playground = $spc;
+ return $spc;
}
# ----- playtrees -----
diff --git a/debian/changelog b/debian/changelog
index ee9c4a3..464a433 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
dgit (4.5~) unstable; urgency=medium
- *
+ Internal changes:
+ * Move $playground global to dgit.
--
diff --git a/dgit b/dgit
index 27dcf1c..9ce7972 100755
--- a/dgit
+++ b/dgit
@@ -153,6 +153,7 @@ sub parseopts_late_defaults();
sub setup_gitattrs(;$);
sub check_gitattrs($$);
+our $playground;
our $keyid;
autoflush STDOUT 1;
@@ -1683,7 +1684,7 @@ our ($dsc_distro, $dsc_hint_tag, $dsc_hint_url);
sub prep_ud () {
dgit_privdir(); # ensures that $dgit_privdir_made is based on $maindir
- fresh_playground 'dgit/unpack';
+ $playground = fresh_playground 'dgit/unpack';
}
sub mktree_in_ud_here () {