summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2015-08-19 16:35:51 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2015-08-19 16:35:51 +0100
commit6111c7d2bd46c48d2b6b7d5b9695f7d349c81c5f (patch)
tree8dcbce97f79505ee4bbb3d30865796f68338502d
parente917ad10a9459a78561be1576801fea4cb0ce082 (diff)
Detect and reject git trees containing debian/source/local-options.
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit4
2 files changed, 5 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index e8c0e61..604d66d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -10,6 +10,7 @@ dgit (1.4~~) UNRELEASED; urgency=low
the error message. (This has been broken forever.)
* In dgit(7), discuss binaries and documentation present in upstream but
removed by rules clean.
+ * Detect and reject git trees containing debian/source/local-options.
--
diff --git a/dgit b/dgit
index 7c76a6f..621288b 100755
--- a/dgit
+++ b/dgit
@@ -1761,6 +1761,10 @@ sub check_not_dirty () {
} else {
failedcmd @cmd;
}
+
+ if (stat_exists "debian/source/local-options") {
+ fail "git tree contains debian/source/local-options";
+ }
}
sub commit_admin ($) {