summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-30 10:21:32 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-30 10:54:53 +0100
commit690272dfb77eefa9277970dafe4bbb47de3b35e1 (patch)
tree641af3cf4ace1dfe9f798a52f0d8953c2bedf8e6
parent38eae0db7f393311667bec9dfe0aa7a514b893bd (diff)
test suite: gpg agent workaround: Neaten the logging.debian/5.5+exp8archive/debian/5.5+exp8
Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog6
-rwxr-xr-xtests/setup/gnupg6
-rwxr-xr-xtests/tstunt/gpg14
-rwxr-xr-xtests/tstunt/gpg-withagent2
4 files changed, 25 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 3611845..3f363e4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+dgit (5.5+exp8) experimental; urgency=medium
+
+ * test suite: gpg agent workaround: Neaten the logging.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sat, 30 Jun 2018 10:54:48 +0100
+
dgit (5.5+exp7) experimental; urgency=medium
* test suite: gpg-agent workaround: Send ps output to stderr (oops)
diff --git a/tests/setup/gnupg b/tests/setup/gnupg
index c88d40b..7a164ef 100755
--- a/tests/setup/gnupg
+++ b/tests/setup/gnupg
@@ -7,10 +7,11 @@ cp $troot/gnupg/* $tmp/gnupg
chmod go-rw $tmp/gnupg/*
export DGIT_TEST_GNUPG_GLOBAL_LOCK=$tmp/gnupg/dgit-test-global-lock
+export DGIT_TEST_GNUPG_LOG=$tmp/gnupg-workarounds.log
setup='
export GNUPGHOME=$tmp/gnupg
- export DGIT_TEST_GNUPG_GLOBAL_LOCK
+ export DGIT_TEST_GNUPG_GLOBAL_LOCK DGIT_TEST_GNUPG_LOG
cat >$tmp/gnupg/gpg-agent.conf <<END
log-file $tmp/gnupg/AGENT.log
@@ -27,6 +28,7 @@ eval "$setup"
gpg --list-secret
-t-setup-done 'DGIT_TEST_GNUPG_GLOBAL_LOCK' 'gnupg' "$setup"
+t-setup-done 'DGIT_TEST_GNUPG_GLOBAL_LOCK DGIT_TEST_GNUPG_LOG' \
+ 'gnupg' "$setup"
t-ok
diff --git a/tests/tstunt/gpg b/tests/tstunt/gpg
index 79d8319..7e12846 100755
--- a/tests/tstunt/gpg
+++ b/tests/tstunt/gpg
@@ -3,4 +3,18 @@ set -e
exec \
with-lock-ex -w "$DGIT_TEST_GNUPG_GLOBAL_LOCK" \
+ sh -c '
+ "$@" 9>&2 2>>"$DGIT_TEST_GNUPG_LOG"
+ rc=$?
+ if [ rc = 0 ]; then exit 0; fi
+ if [ "x$DGIT_TEST_BYHAND" != x ]; then
+ echo >&2 "BYHAND, not catting $DGIT_TEST_GNUPG_LOG"
+ else
+ echo >&2 "########################################"
+ echo >&2 "$DGIT_TEST_GNUPG_LOG"
+ cat >&2 "$DGIT_TEST_GNUPG_LOG"
+ echo >&2 "end of $DGIT_TEST_GNUPG_LOG"
+ fi
+ exit $rc
+ ' x \
"$DGIT_TEST_TROOT"/tstunt/gpg-withagent "$@"
diff --git a/tests/tstunt/gpg-withagent b/tests/tstunt/gpg-withagent
index 4b2ee1a..b7b8bfd 100755
--- a/tests/tstunt/gpg-withagent
+++ b/tests/tstunt/gpg-withagent
@@ -51,7 +51,7 @@ d
set +e
$DGIT_TEST_REAL_GPG \
- --agent-program=$DGIT_STUNT_AGENT "$@"
+ --agent-program=$DGIT_STUNT_AGENT "$@" 2>&9
rc=$?
set -e