summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-18 21:30:56 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-18 21:30:57 +0000
commit76e5c4414c5d0ecd5efdd55c6e93290763873eff (patch)
treeecf6a39083551783bf5ba164f6d358f4b1b794d1
parent48f5dab721e03a47deeef0af45a993b48687bf88 (diff)
dgit: git_get_config: Use confess, not croak
Using croak was simply a mistake. I always wanted a stack trace. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog5
-rwxr-xr-xdgit2
2 files changed, 3 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 7c2faac..d334b39 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,9 +1,8 @@
dgit (3.6~) unstable; urgency=medium
Minor improvements:
- * Call `confess' to print a stack trace when we pass undef to
- shellquote (eg as a result of debugcmd). Turns an undefined
- warning into an explicit internal error.
+ * Use `confess' to print a stack trace in a couple of internal error
+ rcases.
--
diff --git a/dgit b/dgit
index eb42b00..4f85e5c 100755
--- a/dgit
+++ b/dgit
@@ -669,7 +669,7 @@ sub git_get_config ($) {
my ($c) = @_;
foreach my $src (@gitcfgsources) {
my $l = $gitcfgs{$src}{$c};
- croak "$l $c" if $l && !ref $l;
+ confess "internal error ($l $c)" if $l && !ref $l;
printdebug"C $c ".(defined $l ?
join " ", map { messagequote "'$_'" } @$l :
"undef")."\n"