summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-07-01 12:20:50 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-07-01 12:22:42 +0100
commitd561b2284c6e988d70794c9871d44c3bb5f0463f (patch)
tree7aba1e3516fdf8be86aaeb0ec35bacf0b2a6c787
parent96a93d8f6efbf26925d3644f10520e9320066b16 (diff)
dgit: update-vcs-git: Honour --package properly.
Specifically, use package_from_d_control rather than open-coding a substandard implementation. The consequent abolition of $sourcep does mean that if the user specifies the suite `.', and does not specify -p, we needlessly parse debian/control twice. This doesn't really matter. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog3
-rwxr-xr-xdgit5
2 files changed, 4 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 5174822..a45d633 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
dgit (5.7~) unstable; urgency=medium
- *
+ Bugfixes:
+ * dgit update-vcs-git: Honour --package properly.
--
diff --git a/dgit b/dgit
index db12d22..404eab9 100755
--- a/dgit
+++ b/dgit
@@ -4658,11 +4658,10 @@ sub cmd_update_vcs_git () {
}
}
- my $sourcep = parsecontrol 'debian/control', 'debian/control';
- $package = getfield $sourcep, 'Source';
+ package_from_d_control();
my $ctrl;
if ($specsuite eq '.') {
- $ctrl = $sourcep;
+ $ctrl = parsecontrol 'debian/control', 'debian/control';
} else {
$isuite = $specsuite;
get_archive_dsc();