summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-08-03 07:59:34 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-08-03 07:59:35 +0100
commit12948968b9a6e48898a5a704a524930da170cd75 (patch)
tree5a74b1f2b960b6184390b976ce4852eef0cdbf46
parentfabaa10f37c0cea45e0fcb08d3bcaa6ad07191bd (diff)
dgit: Rename --dgit-view-save to --save-dgit-view, leaving an alias.
This name makes more sense. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit5
-rw-r--r--dgit.16
3 files changed, 10 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index cb9f3df..4ea57ef 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ dgit (6.5~) unstable; urgency=medium
* test suite: Add t-tstunt-parsechangelog to many gdr tests.
* test suite: editing a test script overrides DGIT_TESTS_PROGRESSIVE.
+ * dgit: Rename --dgit-view-save to --save-dgit-view, leaving an alias.
--
diff --git a/dgit b/dgit
index 0da0c7f..a5745a5 100755
--- a/dgit
+++ b/dgit
@@ -6953,7 +6953,10 @@ sub parseopts () {
} elsif (m/^--delayed=(\d+)$/s) {
push @ropts, $_;
push @dput, $_;
- } elsif (my ($k,$v) = m/^--(dgit-view)-save=(.+)$/s) {
+ } elsif (my ($k,$v) =
+ m/^--save-(dgit-view)=(.+)$/s ||
+ m/^--(dgit-view)-save=(.+)$/s
+ ) {
push @ropts, $_;
$v =~ s#^(?!refs/)#refs/heads/#;
$internal_object_save{$k} = $v;
diff --git a/dgit.1 b/dgit.1
index a4b1694..4ea34da 100644
--- a/dgit.1
+++ b/dgit.1
@@ -661,7 +661,7 @@ Also,
it can mean that
dgit fails to find necessary git commits.
.TP
-.BR --dgit-view-save= \fIbranch\fR|\fIref\fR
+.BR --save-dgit-view= \fIbranch\fR|\fIref\fR
Specifies that when a split view quilt mode is in operation,
and dgit calculates
(or looks up in its cache)
@@ -681,6 +681,10 @@ And it is only effective with
If ref does not start with refs/
it is taken to to be a branch -
i.e. refs/heads/ is prepended.
+
+.B --dgit-view-save
+is a deprecated alias for
+--save-dgit-view.
.TP
.BI --deliberately- something
Declare that you are deliberately doing