summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-08-19 23:38:09 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-08-19 23:43:08 +0100
commit625ef9cc461653073175be47c4b6a2a9e25c13d1 (patch)
treedfa5b0801bb895b5c8a219f2e6d539d568b4ff7e
parentf0345187fe63a3ef7dcb4ccb90f2b2dd2d384a17 (diff)
git-debrebase: convert-from-*: leave debrebase-last refs
To hint to everyone that this is now a gdr branch. This will make dgit push use gdr make-patches, for example. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog2
-rwxr-xr-xgit-debrebase4
2 files changed, 5 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 3ac55a0..058ce00 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -21,6 +21,8 @@ dgit (6.7~) unstable; urgency=medium
enabled only with special command line option.
* git-debrebase: Check in convert-from-* whether ffq-prev or
debrebase-last indicate that we are already in gdr format.
+ * git-debrebase: convert-from-*: leave debrebase-last refs to
+ hint to everyone that this is now a gdr branch.
--
diff --git a/git-debrebase b/git-debrebase
index af19583..9d0bda0 100755
--- a/git-debrebase
+++ b/git-debrebase
@@ -2421,12 +2421,14 @@ sub begin_convert_from () {
snag 'already-converted',
"ahead of debrebase-last, this is already managed by git-debrebase!"
if $gdrlast_obj && is_fast_fwd $gdrlast_obj, $head;
- return ($head, undef);
+ return ($head, { LastRef => $gdrlast, LastObj => $gdrlast_obj });
}
sub complete_convert_from ($$$$) {
my ($old_head, $new_head, $gi, $mrest) = @_;
ffq_check $new_head;
+ record_gdrlast $gi->{LastRef}, $new_head, $gi->{LastObj}
+ if $gi->{LastRef};
snags_maybe_bail();
update_head_checkout $old_head, $new_head, $mrest;
}