summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-08-19 18:45:51 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-08-19 18:50:34 +0100
commit96768306c386add902ee7a8b733225e9d811b971 (patch)
tree737ec942bb5776515b99e1c49ae2e7e9f0838fe5
parente66c2cf3f7182a3e6f52945636a807ed4a959d5b (diff)
git-debrebase: On rebase, always save ffq-prev
Even if we were both stitched and laundered. Closes:#905975. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog2
-rwxr-xr-xgit-debrebase2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 9ec8a6f..5fe6904 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -11,6 +11,8 @@ dgit (6.7~) unstable; urgency=medium
and analysis performance by factor of ~4.2:1. Closes:#905995.
* git-debrebase: `prepush' is now a silent no-op if the branch is
unstitched. This is more friendly.
+ * git-debrebase: On rebase, always save ffq-prev even if we were
+ both stitched and laundered. Closes:#905975.
--
diff --git a/git-debrebase b/git-debrebase
index c273976..894bad5 100755
--- a/git-debrebase
+++ b/git-debrebase
@@ -1672,7 +1672,7 @@ sub update_head_checkout ($$$) {
sub update_head_postlaunder ($$$) {
my ($old, $tip, $reflogmsg) = @_;
- return if $tip eq $old;
+ return if $tip eq $old && !@deferred_updates;
print "git-debrebase: laundered (head was $old)\n";
update_head $old, $tip, $reflogmsg;
# no tree changes except debian/patches