summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-07-26 06:36:51 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-07-26 10:04:45 +0100
commit0060e3befbe283c90dcf6017ac8261168a6efe10 (patch)
tree2cf9b1b763b238ef0ac0953b7504539bca5c7d59
parente93761ae8a48c2492c3eec035c82bc3dca5e634e (diff)
test suite: Support run-all -p, DGIT_TESTS_PROGRESSIVE
Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--tests/Makefile3
-rwxr-xr-xtests/run-all5
2 files changed, 6 insertions, 2 deletions
diff --git a/tests/Makefile b/tests/Makefile
index d6f78dc..8494284 100644
--- a/tests/Makefile
+++ b/tests/Makefile
@@ -7,7 +7,7 @@ TESTSCRIPTS ?= $(shell tests/enumerate-tests)
TESTNAMES := $(notdir $(TESTSCRIPTS))
all: $(foreach t,$(TESTNAMES),tests/tmp/$t.ok)
- @echo "ALL PASSED"
+ @echo "ALL PASSED$${DGIT_TESTS_PROGRESSIVE+ AT SOME POINT}"
tests/tmp/%.ok:
ifeq ($(DGIT_TEST_RETRY_COUNT),)
@@ -21,3 +21,4 @@ else
echo >&2 "[$$retry] $* TEST FAILED $$rc"; \
done; exit $$rc
endif
+ @touch $@
diff --git a/tests/run-all b/tests/run-all
index 3e40369..c930171 100755
--- a/tests/run-all
+++ b/tests/run-all
@@ -1,12 +1,13 @@
#!/bin/bash
set -e
# convenience script for running the tests outside adt-run
-# usage: tests/using-intree tests/run-all [tests/tests/*]
+# usage: tests/using-intree tests/run-all [-p|--progressive] [tests/tests/*]
set -o pipefail
while [ $# != 0 ]; do
case "$1" in
+ --progressive|-p) shift; export DGIT_TESTS_PROGRESSIVE=y;;
--) shift; break ;;
-*) echo >&2 "run-all: unknown option $1"; exit 20 ;;
*) break ;;
@@ -22,6 +23,8 @@ fi
mkdir -p tests/tmp
+${DGIT_TESTS_PROGRESSIVE+:} rm -f tests/tmp/*.ok
+
export DGIT_GNUPG_STUNT_ERRLOG=$( tty -s ||: )
(