summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2017-11-25 17:13:32 -0700
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-01-06 01:24:04 +0000
commit1ea867d81b069b145a9e1b7a38c97e99e1c40e4f (patch)
treeee92716110988ddd3c77fdab3a5097fc0e4dcf08
parentd6291b24a8338eed8628a9da1eab2810652630e8 (diff)
dgit-maint-merge(7): Restructure "NEW UPSTREAM RELEASES"
Previously, some instructions applicable and needed whether or not upstream tags releases in git were given only for the case where upstream tags releases in git. Thanks Johannes Schauer for noticing this problem. Signed-off-by: Sean Whitton <spwhitton@spwhitton.name>
-rw-r--r--dgit-maint-merge.7.pod56
1 files changed, 36 insertions, 20 deletions
diff --git a/dgit-maint-merge.7.pod b/dgit-maint-merge.7.pod
index fe48609..ed7cdc0 100644
--- a/dgit-maint-merge.7.pod
+++ b/dgit-maint-merge.7.pod
@@ -309,58 +309,74 @@ to git), you can just run dpkg-buildpackage(1) or debuild(1) instead.
=head1 NEW UPSTREAM RELEASES
-=head2 When upstream tags releases in git
+=head2 Obtaining the release
-It's a good idea to preview the merge of the new upstream release.
-First, just check for any new or deleted files that may need
-accounting for in your copyright file:
+=head3 When upstream tags releases in git
=over 4
% git remote update
- % git diff --stat master..1.2.3 -- . ':!debian'
=back
-You can then review the full merge diff:
+=head3 When upstream releases only tarballs
+
+You will need the I<debian/gbp.conf> from "When upstream releases only
+tarballs", above.
+
+Then, either
=over 4
- % git merge-tree `git merge-base master 1.2.3` master 1.2.3 | $PAGER
+ % gbp import-orig --no-merge ../foo_1.2.3.orig.tar.xz
=back
-Once you're satisfied with what will be merged, update your package:
+or if you have a working watch file
=over 4
- % git merge 1.2.3
- % dch -v1.2.3-1 New upstream release.
- % git add debian/changelog && git commit -m changelog
- % git deborig
+ % gbp import-orig --no-merge --uscan
=back
-and you are ready to try a build.
+=head2 Reviewing & merging the release
-=head2 When upstream releases only tarballs
+It's a good idea to preview the merge of the new upstream release.
+First, just check for any new or deleted files that may need
+accounting for in your copyright file:
-You will need the I<debian/gbp.conf> from "When upstream releases only
-tarballs", above.
+=over 4
-Then, either
+ % git diff --stat master..1.2.3 -- . ':!debian'
+
+=back
+
+You can then review the full merge diff:
=over 4
- % gbp import-orig ../foo_1.2.2.orig.tar.xz
+ % git merge-tree `git merge-base master 1.2.3` master 1.2.3 | $PAGER
=back
-or if you have a working watch file
+Once you're satisfied with what will be merged, update your package:
=over 4
- % gbp import-orig --uscan
+ % git merge 1.2.3
+ % dch -v1.2.3-1 New upstream release.
+ % git add debian/changelog && git commit -m changelog
+
+=back
+
+If you obtained a tarball from upstream, you are ready to try a build.
+If you merged a git tag from upstream, you will first need to generate
+a tarball:
+
+=over 4
+
+ % git deborig
=back