summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-08 12:11:59 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-09 02:18:16 +0000
commit6ac21629eae807dcd628d6ffec1eed0e087d22a2 (patch)
tree50cef609535bde9ac157e491f089aa32d43657b8
parent1af545d050a9f129e7e42ec6fd2763fd8a3514aa (diff)
dgit: conflg handling: Undocumented --config-lookup-explode= feature.
For testing. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit5
2 files changed, 6 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index f404d5a..8402293 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -12,6 +12,7 @@ dgit (3.0~) unstable; urgency=medium
Minor new feature:
* distro alias facility in config space. (Primarily for testing.)
+ * Undocumented --config-lookup-explode= feature. (For testing.)
dgit-badcommit-fixup:
* Do not investigate symrefs. Closes:#850547.
diff --git a/dgit b/dgit
index 02d0b92..e4987ae 100755
--- a/dgit
+++ b/dgit
@@ -6320,6 +6320,11 @@ sub parseopts () {
# undocumented, for testing
push @ropts, $_;
$need_split_build_invocation = 1;
+ } elsif (m/^--config-lookup-explode=(.+)$/s) {
+ # undocumented, for testing
+ push @ropts, $_;
+ $gitcfgs{cmdline}{$1} = 'CONFIG-LOOKUP-EXPLODE';
+ # ^ it's supposed to be an array ref
} elsif (m/^(--[-0-9a-z]+)(=|$)/ && ($oi = $valopts_long{$1})) {
$val = $2 ? $' : undef; #';
$valopt->($oi->{Long});