summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-07-03 23:01:25 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-07-03 23:12:42 +0100
commit78b07fbae13bbed34172c1bbe14235099c91e2a6 (patch)
tree96f70b8fe99c06fe988d22feb551d62a9429e025
parente336da03c1d9568dc889e18659c483d5eb047c99 (diff)
Test suite: run-all should use make -k
Otherwise one failure causes the tests to be abandoned, which is not usually desirable.
-rwxr-xr-xtests/run-all2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/run-all b/tests/run-all
index f298cb7..b5c5bb0 100755
--- a/tests/run-all
+++ b/tests/run-all
@@ -12,4 +12,4 @@ if [ $# != 0 ]; then
fi
set -x
-exec make $jcpus -f tests/Makefile "$@"
+exec make $jcpus -k -f tests/Makefile "$@"