summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-07-23 11:00:09 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-07-23 11:00:10 +0100
commit94fa2654f99556f17b0c98712b29d1bec3a8f91b (patch)
treed0d3e368bb443f6ce2aa04966c6001ceacb39bca
parent9ee8857bdfcfe774a33811a60d61012fffd5dba2 (diff)
apt-get method: when apt does not update release files, print hint
Unconditionally print hint about noatime. This problem seems to occur quite rarely (noatime is out of fashion nowadays, and I haven't seen any other causes) so it doesn't seem worth fiddling about writing code to determine the mount options. Instead, print a hint and let the user investigate. Closes:#851873. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit9
2 files changed, 10 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 4f35940..265ecb0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,8 @@
dgit (5.11~) unstable; urgency=medium
* test suite: unset VISUAL, which interferes. Closes:#904308.
+ * apt-get method: when apt does not update release files,
+ unconditionally print hint about noatime. Closes:#851873.
--
diff --git a/dgit b/dgit
index 357adc9..9c58fdf 100755
--- a/dgit
+++ b/dgit
@@ -1237,7 +1237,14 @@ END
}
my @inreleasefiles = grep { m#/InRelease$# } @releasefiles;
@releasefiles = @inreleasefiles if @inreleasefiles;
- die "apt updated wrong number of Release files (@releasefiles), erk"
+ if (!@releasefiles) {
+ fail <<END;
+apt seemed to not to update dgit's cached Release files for $isuite.
+(Perhaps $cache
+ is on a filesystem mounted `noatime'; if so, please use `relatime'.)
+END
+ }
+ die "apt updated too many Release files (@releasefiles), erk"
unless @releasefiles == 1;
($aptget_releasefile) = @releasefiles;