summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2013-08-23 12:24:16 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2013-08-23 12:24:16 +0100
commit9d4fe1fe846ac76795a42661aa4bb73335c07aad (patch)
tree513e8ef20db6165a28ff39efcdd8cdb251706782
parent0783d2b7923f56e004808cd68da81a6a4178f4fb (diff)
In push, do git fetch as well as archive fetch, or archive fetch can fail.debian/0.8
-rw-r--r--debian/changelog4
-rwxr-xr-xdgit3
2 files changed, 6 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index ed269fe..87d00e1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,8 +5,10 @@ dgit (0.8) unstable; urgency=low
* When creating repos in dgit-repos (using the ssh-cmd method),
copy _template rather than using mkdir and git init.
Closes: #720522.
+ * In push, do git fetch as well as archive fetch, or archive
+ fetch can fail.
- -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 23 Aug 2013 12:15:10 +0100
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 23 Aug 2013 12:24:09 +0100
dgit (0.7) unstable; urgency=low
diff --git a/dgit b/dgit
index 8911c8e..f9c46c0 100755
--- a/dgit
+++ b/dgit
@@ -938,6 +938,9 @@ sub cmd_push {
} else {
badusage "incorrect arguments to dgit push";
}
+ if (check_for_git()) {
+ git_fetch_us();
+ }
if (fetch_from_archive()) {
is_fast_fwd(lrref(), 'HEAD') or die;
} else {