summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-11-07 20:58:12 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-11-07 20:58:13 +0000
commit9dc4ad19c97b17d28ad1440b6fea85418fcc84ac (patch)
tree76505e2dc287e98117504363c482c69097e26c66
parent6f4ecf492c297aa6a1f0c2b2652225cd40ce72be (diff)
Fix an unconditional print that was supposed to be a printdebug:
origs <blah>.orig.tar.gz f.same=1 #f._differ=-1 Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit3
2 files changed, 4 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 32064c1..691b783 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -10,6 +10,8 @@ dgit (2.10~) unstable; urgency=medium
the suite, as documented in the manpage.
* New comma-separated multiple-suite merging facility (readonly),
so that users can easily track "jessie, or jessie-security".
+ * Fix an unconditional print that was supposed to be a printdebug:
+ origs <blah>.orig.tar.gz f.same=1 #f._differ=-1
--
diff --git a/dgit b/dgit
index b7e7f7e..6a74307 100755
--- a/dgit
+++ b/dgit
@@ -1891,7 +1891,8 @@ END
push @found_differ, "archive $h->{filename}: ".join "; ", @differ
if @differ;
}
- print "origs $file f.same=$found_same #f._differ=$#found_differ\n";
+ printdebug "origs $file f.same=$found_same".
+ " #f._differ=$#found_differ\n";
if (@found_differ && !$found_same) {
fail join "\n",
"archive contains $file with different checksum",