summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-21 01:20:01 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-21 01:32:31 +0100
commitc4a96d7a9ed9f83abed11a84f7fe068e27dee2b1 (patch)
treee2180b460ff8e33b7470f1ef57e4d6ae638e3246
parentc0df25cd65b0172d5130e01a73aa610c3b0dd105 (diff)
dgit: --overwrite now no longer crashes if there is no $archive_hash
Ie there is nothing to overwrite (eg, when used with --new). Instead, it is simply ignored, as it is ignored in situations where the push is fast forward. Closes:#863576. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog3
-rwxr-xr-xdgit3
2 files changed, 5 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index b34b4a0..437bd53 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -14,6 +14,9 @@ dgit (5.2~) unstable; urgency=medium
happes to be a noop) but --dry-run was specified, fail with an
explanation, rather than looping with a false coplaint about git
fetch. Closes:#871317.
+ * --overwrite now no longer crashes if there is nothing to overwrite
+ (eg, when used with --new). Instead, it is simply ignored, as it is
+ ignored in situations where the push is fast forward. Closes:#863576.
test suite:
* Use nproc(1) rather than Sys::CPU. This is more portable and does not
diff --git a/dgit b/dgit
index 3409e18..5a6b2b6 100755
--- a/dgit
+++ b/dgit
@@ -4301,7 +4301,8 @@ END
}
}
- if (defined $overwrite_version && !defined $maintviewhead) {
+ if (defined $overwrite_version && !defined $maintviewhead
+ && $archive_hash) {
$dgithead = plain_overwrite_pseudomerge($clogp,
$dgithead,
$archive_hash);