summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2013-08-25 15:59:56 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2013-08-25 15:59:56 +0100
commitdac79ba60f22d978a2b3f834358c7f865bcf131a (patch)
treeaa715e52b41cfa314bf411ddcc0cedbadbbf61bb
parentafd3aa8b36b05f6cf01b17d553fc14250afacaec (diff)
Autogenerated quilt patch fixup patch Description contains several recent git commits, rather than implying that the patch corresponds exactly to the top git commit.
-rw-r--r--debian/changelog3
-rwxr-xr-xdgit13
2 files changed, 12 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 66f74cf..fea5595 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,9 @@ dgit (0.11) unstable; urgency=low
* Fix bug which would make quilt patch fixup fail if git status
produced "M" lines.
+ * Autogenerated quilt patch fixup patch Description contains several
+ recent git commits, rather than implying that the patch corresponds
+ exactly to the top git commit.
* Use "ftp.debian.org" not "http.debian.net" as the default Debian
archive. (http.debian.net tends to defeat certain kinds of cacheing,
and can also have more skew.)
diff --git a/dgit b/dgit
index 878065f..0adf302 100755
--- a/dgit
+++ b/dgit
@@ -992,18 +992,23 @@ sub build_maybe_quilt_fixup () {
chomp;
return unless madformat($_);
# sigh
+ my $clogp = parsechangelog();
+ my $version = getfield $clogp, 'Version';
+ my $author = getfield $clogp, 'Maintainer';
my $headref = rev_parse('HEAD');
my $time = time;
+ my $ncommits = 3;
my $patchname = "auto-$version-$headref-$time";
- my $author = cmdoutput @git, qw(log -n1), '--pretty=format:%an <%ae>';
- my $msg = cmdoutput @git, qw(log -n1), "--pretty=format:%s\n%b";
+ my $msg = cmdoutput @git, qw(log), "-n$ncommits";
my $descfn = ".git/dgit/quilt-description.tmp";
open O, '>', $descfn or die "$descfn: $!";
$msg =~ s/\n/\n /g;
$msg =~ s/^\s+$/ ./mg;
print O <<END or die $!;
-Description: $msg
- [generated from git commit $headref]
+Description: Automatically generated patch ($clogp->{Version})
+ Last (up to) $ncommits git changes, FYI:
+ .
+ $msg
Author: $author
---