summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2015-05-17 00:58:51 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2015-05-31 11:54:13 +0100
commite3a629cbad9501d8e92b7ed04f7c545583c8550b (patch)
tree33cd51be0001d332dce90ac1fe9649a58b4029cd
parent4932712487439e6e8476527d32fdce8487c755c3 (diff)
Tests: debpolicy-newreject: Make each tree a new version (with dch and debcommit)
-rwxr-xr-xtests/tests/debpolicy-newreject18
1 files changed, 14 insertions, 4 deletions
diff --git a/tests/tests/debpolicy-newreject b/tests/tests/debpolicy-newreject
index 2a2e8f3..93e188d 100755
--- a/tests/tests/debpolicy-newreject
+++ b/tests/tests/debpolicy-newreject
@@ -7,10 +7,19 @@ t-prep-newpackage example 1.0
cd $p
+revision=1
+t-commit () {
+ local msg=$1
+ v=1.$revision
+ dch -v$v --distribution unstable "$1"
+ git add debian/changelog
+ debcommit
+ revision=$(( $revision + 1 ))
+}
echo FORBIDDEN >debian/some-file
git add debian/some-file
-git commit -m 'Commit a forbidden thing'
+t-commit 'Commit a forbidden thing'
bad=`git rev-parse HEAD:debian/some-file`
t-policy-admin taint --global "$bad" "forbidden for testing"
@@ -21,7 +30,8 @@ t-dgit push --new
t-git-dir-check enoent
git reset --hard HEAD~
-git commit --allow-empty -m 'will vanish from NEW'
+t-commit 'will vanish from NEW'
+vanished=$v
t-dgit build
t-dgit push --new
t-git-dir-check secret
@@ -38,10 +48,10 @@ t-git-dir-time-passes
t-policy-periodic
t-git-dir-check enoent
-git commit --allow-empty -m 'should require --deliberately...questionable'
+t-commit 'should require --deliberately...questionable'
t-dgit build
-t-expect-fail 'tag debian/1.0 referred to this object.*all previously pushed versions were found to have been removed' \
+t-expect-fail "tag debian/$vanished referred to this object.*all previously pushed versions were found to have been removed" \
t-dgit push --new
t-git-dir-check enoent