summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2019-06-18 20:02:30 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2019-06-28 12:45:38 +0100
commitb0e869bfd2247ab7465547d1363254f3d97f6504 (patch)
tree1d81fb73e626971fd48edb1d5811c6092e699a22
parent9e33aefbc2d0b2cebdadba42bdf170ff608b5ac9 (diff)
dgit: Move git chedckout master out of quiltify
This is closer to where it is going to be used, and a bit less confusing. No functional change. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rwxr-xr-xdgit3
1 files changed, 1 insertions, 2 deletions
diff --git a/dgit b/dgit
index f0a1e76..dd052fe 100755
--- a/dgit
+++ b/dgit
@@ -5815,8 +5815,6 @@ sub quiltify ($$$$) {
runcmd @git, qw(checkout -q), $cc, qw(debian/changelog);
}
-
- runcmd @git, qw(checkout -q master);
}
sub build_maybe_quilt_fixup () {
@@ -6303,6 +6301,7 @@ END
progress f_ "starting quiltify (multiple patches, %s mode)", $quilt_mode;
quiltify($clogp,$headref,$oldtiptree,\@failsuggestion);
+ runcmd @git, qw(checkout -q master);
if (!open P, '>>', ".pc/applied-patches") {
$!==&ENOENT or confess "$!";