summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2021-09-07 22:39:57 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2021-09-07 22:41:05 +0100
commit86f59a365b6f30820c15d356a23d7c6ae5946351 (patch)
tree66987f2680716941febae8a37d7d8144d95d3a65
parent970decb0d2efce837ee25179f6307b4290119d21 (diff)
tests: Introduce t-debchange and set DEBEMAIL
Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--tests/lib8
1 files changed, 6 insertions, 2 deletions
diff --git a/tests/lib b/tests/lib
index 749509c..ee8d14f 100644
--- a/tests/lib
+++ b/tests/lib
@@ -1126,7 +1126,7 @@ t-merge-conflicted-stripping-conflict-markers () {
t-commit () {
local msg=$1
v=${2:-${majorv:-1}.$revision}
- $troot/tstunt/debchange \
+ t-debchange \
--force-distribution -v$v --distribution ${3:-unstable} "$1"
git add debian/changelog
debcommit
@@ -1144,10 +1144,14 @@ t-dch-commit-r () {
}
t-dch-commit () {
- $troot/tstunt/debchange "$@"
+ t-debchange "$@"
git commit -m "dch $*" debian/changelog
}
+t-debchange () {
+ DEBEMAIL=dgit-tests@example.org $troot/tstunt/debchange "$@"
+}
+
t-git-config () {
git config --global "$@"
}