summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2022-01-02 01:03:44 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2022-01-02 01:43:29 +0000
commitc3234fb740efb8710d5a1d8097cc0f45517d1853 (patch)
treeca12944d0f81b09c510326f3212d0cf4ce30c48b
parent8bd315e819fa438062dd8f241aac8910d29e86e1 (diff)
tests: Use t-debchange in some places instead of dch
Raw dch can hang reading stdin for confirmation because we forgot to set DEBEMAIL. Empirically it works some of the time. Maybe the parallel test ordering connects only some of the tests' stdin to the terminal, or something. Anyway, we have t-debchange and so we should be using it. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rwxr-xr-xtests/tests/gdr-merge-conflicts4
-rwxr-xr-xtests/tests/mismatches-contents2
2 files changed, 3 insertions, 3 deletions
diff --git a/tests/tests/gdr-merge-conflicts b/tests/tests/gdr-merge-conflicts
index 5a3f243..05b5480 100755
--- a/tests/tests/gdr-merge-conflicts
+++ b/tests/tests/gdr-merge-conflicts
@@ -63,8 +63,8 @@ git merge --no-edit -s ours other
# we have to do a little dance to make this not a pseudomerge
t-git-next-date
-dch -a 'Merge, only conflict was in debian/changelog'
-t-dch-r-rune dch
+t-debchange -a 'Merge, only conflict was in debian/changelog'
+t-dch-r-rune t-debchange
git commit -a --amend --no-edit
wreckage-before
diff --git a/tests/tests/mismatches-contents b/tests/tests/mismatches-contents
index ea0d724..e424016 100755
--- a/tests/tests/mismatches-contents
+++ b/tests/tests/mismatches-contents
@@ -11,7 +11,7 @@ ln -s $troot/pkg-srcs/${p}_${v%-*}.orig.tar.* .
cd $p
v=1.0-1
-dch -v $v -D unstable -m 'Make a revision'
+t-debchange -v $v -D unstable -m 'Make a revision'
echo foo >us-file
git add us-file debian/changelog
git commit -m "Commit $v"