summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2019-07-21 01:52:27 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2019-07-21 16:22:23 +0100
commit18328a4af50e91cc8899bb519548b505af548abe (patch)
treebbdc8686dfad4bb80d771088446cd6959151691e
parentcec005037f5b62cb17094df53fb25c066d6a9705 (diff)
git-playtree-setup: Provide to git-debpush
Not used yet, so no overall functional change to the script. The .deb has a new file. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk> Signed-off-by: Sean Whitton <spwhitton@spwhitton.name>
-rw-r--r--debian/git-debpush.install1
-rwxr-xr-xdebian/rules3
-rwxr-xr-xgit-debpush1
3 files changed, 5 insertions, 0 deletions
diff --git a/debian/git-debpush.install b/debian/git-debpush.install
new file mode 100644
index 0000000..563b42f
--- /dev/null
+++ b/debian/git-debpush.install
@@ -0,0 +1 @@
+git-playtree-create /usr/share/git-debpush
diff --git a/debian/rules b/debian/rules
index 4e44118..6ce2c3b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -65,6 +65,9 @@ specpkg_install_gdp: tok=gdp
specpkg_install_gdp: specperl=/usr/share/dgit/gdp/perl5
specpkg_install_gdp:
$(specpkg_install_common)
+ set -x; perl -i -pe 'next unless m/###substituted###/;' \
+ -e 's{^(git_playtree_setup)=.*}{$$1=/usr/share/$p/git-playtree-setup};' \
+ debian/$(p)/usr/bin/*
specpkg_install_%: tok=$*
specpkg_install_%: specperl=/usr/share/dgit/$(tok)/perl5
diff --git a/git-debpush b/git-debpush
index 1bfb093..ca737d2 100755
--- a/git-debpush
+++ b/git-debpush
@@ -38,6 +38,7 @@ set -o pipefail
# **** Helper functions and variables ****
us="$(basename $0)"
+git_playtree_create=git-playtree-create ###substituted###
cleanup() {
if [ -d "$temp" ]; then