summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2019-07-21 16:39:58 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2019-07-21 18:01:18 +0100
commit224ca6b4a472fb9bb70f455bcea6733f9c9e99bc (patch)
treecb16cffefdf59ceb174dba4bfa165554b523f5c2
parent1e947003e9b48254d349f000eaab3849511eb55e (diff)
git-playtree-setup: Rename from git-playtree-create
The name is from when I thought it would actually mkdir. But it doesn't. No overall functional change. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--Debian/Dgit.pm4
-rw-r--r--Makefile2
-rw-r--r--debian/git-debpush.install2
-rwxr-xr-xdebian/rules6
-rwxr-xr-xgit-debpush4
-rwxr-xr-xgit-playtree-setup (renamed from git-playtree-create)0
-rw-r--r--tests/lib-core4
7 files changed, 11 insertions, 11 deletions
diff --git a/Debian/Dgit.pm b/Debian/Dgit.pm
index 8ed8364..3ac042c 100644
--- a/Debian/Dgit.pm
+++ b/Debian/Dgit.pm
@@ -1055,7 +1055,7 @@ sub playtree_setup () {
# $maindir_gitdir contains our main working "dgit", HEAD, etc.
# $maindir_gitcommon the shared stuff, including .objects
- # we need to invoke git-playtree-create via git because
+ # we need to invoke git-playtree-setup via git because
# there may be config options it needs which are only available
# to us, sensibly, in @git
@@ -1066,7 +1066,7 @@ sub playtree_setup () {
# @INC is conveniently available.
my $newpath = join ':', +(grep { !m/:/ } @INC),
'/usr/share/dgit', $ENV{PATH};
- runcmd qw(env), "PATH=$newpath", @git, qw(playtree-create .);
+ runcmd qw(env), "PATH=$newpath", @git, qw(playtree-setup .);
ensuredir '.git/info';
open GA, "> .git/info/attributes" or confess "$!";
diff --git a/Makefile b/Makefile
index c8937fc..c4f1673 100644
--- a/Makefile
+++ b/Makefile
@@ -34,7 +34,7 @@ infraexamplesdir=$(prefix)/share/doc/dgit-infrastructure/examples
txtdocdir=$(prefix)/share/doc/dgit
absurddir=$(prefix)/share/dgit/absurd
-PROGRAMS=dgit dgit-badcommit-fixup git-playtree-create
+PROGRAMS=dgit dgit-badcommit-fixup git-playtree-setup
MAN1PAGES=dgit.1
MAN7PAGES=dgit.7 \
diff --git a/debian/git-debpush.install b/debian/git-debpush.install
index 563b42f..afba498 100644
--- a/debian/git-debpush.install
+++ b/debian/git-debpush.install
@@ -1 +1 @@
-git-playtree-create /usr/share/git-debpush
+git-playtree-setup /usr/share/git-debpush
diff --git a/debian/rules b/debian/rules
index 6ce2c3b..4d1a760 100755
--- a/debian/rules
+++ b/debian/rules
@@ -43,7 +43,7 @@ override_dh_auto_install: specpkg_install_gdp \
make install prefix=/usr DESTDIR=debian/dgit
make -C po install prefix=/usr DESTDIR=../debian/tmp \
SUPPRESS_PO_UPDATE=1 S=''
- mv debian/dgit/usr/bin/git-playtree-create debian/dgit/usr/share/dgit
+ mv debian/dgit/usr/bin/git-playtree-setup debian/dgit/usr/share/dgit
make -C po4a install DESTDIR=../debian/tmp S=''
override_dh_missing:
@@ -76,7 +76,7 @@ specpkg_install_%:
# # Most of the Perl modules in this package live in
# # $(specperl). The exception is Debian::Dgit::Infra, which
# # lives in $(globalperl) and adds $(specperl) to @INC.
-# # We also abuse this for git-playtree-create. In .debs, this
+# # We also abuse this for git-playtree-setup. In .debs, this
# # goes in the per-.deb @INC dir. See Dgit.pm::playtree_setup.
set -ex; \
base=debian/$(p); \
@@ -85,7 +85,7 @@ specpkg_install_%:
dst=$${base}$(globalperl)/$${mod}; \
mkdir -p $${dst%/*}; \
mv -f $$src $$dst; \
- install -m 755 git-playtree-create $${base}$(specperl); \
+ install -m 755 git-playtree-setup $${base}$(specperl); \
perl -i -p -e 'next unless m/###substituted###/;' \
-e 'next unless s/^# (?=unshift \@INC,)//;' \
-e 'die unless s{q\{\S+\}}{q{$(specperl)}};' \
diff --git a/git-debpush b/git-debpush
index 0be0bf4..5b99e72 100755
--- a/git-debpush
+++ b/git-debpush
@@ -38,8 +38,8 @@ set -o pipefail
# **** Helper functions and variables ****
us="$(basename $0)"
-git_playtree_create=git-playtree-create ###substituted###
-git_playtree_create=${DEBPUSH_GIT_PLAYTREE_CREATE-$git_playtree_create}
+git_playtree_setup=git-playtree-setup ###substituted###
+git_playtree_setup=${DEBPUSH_GIT_PLAYTREE_SETUP-$git_playtree_setup}
cleanup() {
if [ -d "$temp" ]; then
diff --git a/git-playtree-create b/git-playtree-setup
index 5d890a0..5d890a0 100755
--- a/git-playtree-create
+++ b/git-playtree-setup
diff --git a/tests/lib-core b/tests/lib-core
index cbcd602..7e98acf 100644
--- a/tests/lib-core
+++ b/tests/lib-core
@@ -15,10 +15,10 @@ t-set-intree () {
: ${DGIT_INFRA_PFX:=$DGIT_TEST_INTREE${DGIT_TEST_INTREE:+/infra/}}
: ${DGIT_GITDEBREBASE_TEST:=$DGIT_TEST_INTREE/git-debrebase}
: ${DGIT_MANPAGES_SOURCE_DIR:=$DGIT_TEST_INTREE}
- : ${DEBPUSH_GIT_PLAYTREE_CREATE:=$DGIT_TEST_INTREE/git-playtree-create}
+ : ${DEBPUSH_GIT_PLAYTREE_SETUP:=$DGIT_TEST_INTREE/git-playtree-setup}
export DGIT_TEST DGIT_BADCOMMIT_FIXUP
export DGIT_REPOS_SERVER_TEST DGIT_SSH_DISPATCH_TEST
- export DGIT_MANPAGES_SOURCE_DIR DEBPUSH_GIT_PLAYTREE_CREATE
+ export DGIT_MANPAGES_SOURCE_DIR DEBPUSH_GIT_PLAYTREE_SETUP
export PERLLIB="$DGIT_TEST_INTREE${PERLLIB:+:}${PERLLIB}"
}