summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-23 12:52:19 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-23 12:52:25 +0100
commit459926bd714e0136281d99ac0d9f7b3d8c99fe8c (patch)
treeac8a5cfc1d2ae53d10a482ea0029f0bc9f9f4f34
parent19669291927ee91dbea3c47a412161b32859df88 (diff)
solit brain: Do not crash in when the two brains are actually identical.
The dgit-view ref is created by quiltify_splitbrain_needed, which is not always called. But, quiltify_splitbrain_needed's other function is to switch branches. If it was called then HEAD will refer to dgit-view. If it wasn't then the original HEAD is fine. Closes:#841770. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 75515ee..c0c45a1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,8 @@ dgit (2.5~) unstable; urgency=medium
and improve performance by amortising gnupg migration cost.
* Switch to new archive/ tag format by default, even in
non-split-brain mode.
+ * Do not crash in split brain quilt modes when the two brains are
+ actually identical. Closes:#841770.
--
diff --git a/dgit b/dgit
index 6cdf8d2..5ee61ef 100755
--- a/dgit
+++ b/dgit
@@ -3909,7 +3909,7 @@ Commit patch to update .gitignore
END
}
- my $dgitview = git_rev_parse 'refs/heads/dgit-view';
+ my $dgitview = git_rev_parse 'HEAD';
changedir '../../../..';
# When we no longer need to support squeeze, use --create-reflog