summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-10-04 11:43:19 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-10-04 16:33:23 +0100
commit707e502d2fb71f98f990edc12bd5fbd3d32dae52 (patch)
tree376a23e3a971d0792ebeba7f9dd1bd17da75b9f5
parent94256e8ad7b7450c96a1a1bbaf330c136380ebf1 (diff)
i18n: Provide `i18n-update' target in toplevel Makefile
With a convenience alias `i18n'. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--Makefile4
-rw-r--r--po/Makefile2
-rw-r--r--po4a/Makefile2
3 files changed, 7 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 3215fec..a0854a1 100644
--- a/Makefile
+++ b/Makefile
@@ -127,6 +127,10 @@ installdirs-infra:
list-manpages:
@echo $(MANPAGES)
+i18n i18n-update:
+ $(MAKE) -C po update
+ $(MAKE) -C po4a update
+
check installcheck:
clean distclean mostlyclean maintainer-clean:
diff --git a/po/Makefile b/po/Makefile
index 0053f52..cc4a062 100644
--- a/po/Makefile
+++ b/po/Makefile
@@ -115,6 +115,8 @@ clean:
pofiles: $(POFILES)
+update: pofiles check
+
check: $(if $(SUPPRESS_PO_UPDATE),,pofiles)
$S set -e; for file in $(POFILES); do \
lang=`echo $$file | sed 's/\.po//'`; \
diff --git a/po4a/Makefile b/po4a/Makefile
index 6b1792a..c759ce8 100644
--- a/po4a/Makefile
+++ b/po4a/Makefile
@@ -82,7 +82,7 @@ default: pofiles
include ../i18n-common.make
PO4A ?= po4a
-all: translated
+all update: translated
pofiles: po4a.cfg
$(PO4A) --no-translations $<