summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-18 21:32:33 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-18 21:32:36 +0000
commit7dcdcdd7c58d7ea097088f76909b04d0ba0db5f6 (patch)
tree17af580f709d5f539907cb30c1e881137b779fe7
parent76e5c4414c5d0ecd5efdd55c6e93290763873eff (diff)
dgit: git_lrfetch_sane: Take $url, and pass it right value in import
This means we actually use the url from a Dgit .dsc field naming an unknown distro. Closes:#851728. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog4
-rwxr-xr-xdgit11
2 files changed, 9 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index d334b39..ce2b0b7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,9 @@
dgit (3.6~) unstable; urgency=medium
+ Bugfixes:
+ * Actually use the url from a Dgit .dsc field naming an unknown distro.
+ Closes:#851728.
+
Minor improvements:
* Use `confess' to print a stack trace in a couple of internal error
rcases.
diff --git a/dgit b/dgit
index 4f85e5c..b7888af 100755
--- a/dgit
+++ b/dgit
@@ -2572,7 +2572,7 @@ sub lrfetchref_used ($) {
}
sub git_lrfetch_sane {
- my ($supplementary, @specs) = @_;
+ my ($url, $supplementary, @specs) = @_;
# Make a 'refs/'.lrfetchrefs.'/*' be just like on server,
# at least as regards @specs. Also leave the results in
# %lrfetchrefs_f, and arrange for lrfetchref_used to be
@@ -2603,8 +2603,6 @@ sub git_lrfetch_sane {
# git fetch to try to generate it. If we don't manage to generate
# the target state, we try again.
- my $url = access_giturl();
-
printdebug "git_lrfetch_sane suppl=$supplementary specs @specs\n";
my $specre = join '|', map {
@@ -2744,7 +2742,8 @@ sub git_fetch_us () {
push @specs, $rewritemap;
push @specs, qw(heads/*) if deliberately_not_fast_forward;
- git_lrfetch_sane 0, @specs;
+ my $url = access_giturl();
+ git_lrfetch_sane $url, 0, @specs;
my %here;
my @tagpats = debiantags('*',access_nomdistro);
@@ -2873,13 +2872,13 @@ END
or fail <<END;
.dsc Dgit metadata is in context of distro $dsc_distro
for which we have no configured url;
-.dsc provices hinted url with protocol $proto which is unsafe.
+.dsc provides hinted url with protocol $proto which is unsafe.
(can be overridden by config - consult documentation)
END
$url = $dsc_hint_url;
}
- git_lrfetch_sane 1, @fetch;
+ git_lrfetch_sane $url, 1, @fetch;
return $lrf;
};