summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-23 19:17:45 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-30 19:50:47 +0000
commitcb1a4dcdcdb0bb00d38eb38a8b0285f8e81965b5 (patch)
tree7eee599869755d95846cc1538429f7de8d249a82
parent06a2e047d5fc1eebb96c9362984534287df76987 (diff)
Properly look for .origs etc. in .., fetching them less often.
Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit2
2 files changed, 2 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 4ff91b9..4d553f6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,7 @@ dgit (2.9~) unstable; urgency=low
* Split brain mode: Fix --new. Closes:#842354.
* During push, automatically calculate which .origs are required,
so user never needs [--ch:]-sa or [--ch:]-sd. Closes:#829116.
+ * Properly look for .origs etc. in .., fetching them less often.
--
diff --git a/dgit b/dgit
index 0330552..2e70081 100755
--- a/dgit
+++ b/dgit
@@ -1830,7 +1830,7 @@ sub generate_commits_from_dsc () {
printdebug "considering linking $f: ";
- link_ltarget "../../../$f", $f
+ link_ltarget "../../../../$f", $f
or ((printdebug "($!) "), 0)
or $!==&ENOENT
or die "$f $!";