summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2022-09-03 16:46:34 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2022-09-03 18:12:46 +0100
commit330eeb5cbc8dcd3bf7df790399e50256983f6847 (patch)
tree3f9c5a55edcf873235c451f849a7ad9d84fda398
parent7d1f26b2a495bfa381fb5f07e26326b5265448ac (diff)
dgit: quilt fixup: Remove some now-unneeded "git checkout"
quiltify_make_dpkg_patch now uses git diff which doesn't require us to update the working tree. We still need to do it at the end, because the next steps expect it. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rwxr-xr-xdgit5
1 files changed, 1 insertions, 4 deletions
diff --git a/dgit b/dgit
index 5cf5fec..3933cec 100755
--- a/dgit
+++ b/dgit
@@ -5893,17 +5893,14 @@ sub quiltify ($$$$) {
$index++) { }
$!==ENOENT or confess "$patchname$index $!";
- runcmd @git, qw(checkout -q), $cc;
- runcmd @git, qw(checkout -q), $target, qw(debian/changelog);
-
quiltify_make_dpkg_patch
$p->{Commit} ,$cc,
"$patchname$index", $author, $msg,
"Date: $commitdate\n".
"X-Dgit-Generated: $clogp->{Version} $cc\n";
- runcmd @git, qw(checkout -q), $cc, qw(debian/changelog);
}
+ runcmd @git, qw(checkout -q), $target;
}
sub build_maybe_quilt_fixup () {