summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2022-09-03 16:47:23 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2022-09-03 18:12:46 +0100
commitc6b038dc1eb90162f58cbebf62b8849d5b38ad18 (patch)
treeaef21666f2fe30ff0e76f3e13bfc51ca7e11492f
parentdee0dbe1dff5fc529c2568b08625d3d0afbae2b3 (diff)
dgit: quiltify_make_dpkg_patch: Pass git treeish's
It will need these for running git diff. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rwxr-xr-xdgit12
1 files changed, 8 insertions, 4 deletions
diff --git a/dgit b/dgit
index c53a952..0468ac1 100755
--- a/dgit
+++ b/dgit
@@ -5384,8 +5384,8 @@ our $dscfn;
our $fakeeditorenv = 'DGIT_FAKE_EDITOR_QUILT';
-sub quiltify_make_dpkg_patch ($$$;$) {
- my ($patchname,$author,$msg, $xinfo) = @_;
+sub quiltify_make_dpkg_patch ($$$$$;$) {
+ my ($oldtreeish,$newtreeish, $patchname,$author,$msg, $xinfo) = @_;
$xinfo //= '';
mkpath '.git/dgit'; # we are in playtree
@@ -5784,7 +5784,9 @@ sub quiltify ($$$$) {
my $ncommits = 3;
my $msg = cmdoutput @git, qw(log), "-n$ncommits";
- quiltify_make_dpkg_patch "auto-$version-$target-$time",
+ quiltify_make_dpkg_patch
+ $oldtiptree, $target,
+ "auto-$version-$target-$time",
(getfield $clogp, 'Maintainer'),
(f_ "Automatically generated patch (%s)\n".
"Last (up to) %s git changes, FYI:\n\n",
@@ -5898,7 +5900,9 @@ sub quiltify ($$$$) {
# overwritten.
runcmd @git, qw(checkout -q), $target, qw(debian/changelog);
- quiltify_make_dpkg_patch "$patchname$index", $author, $msg,
+ quiltify_make_dpkg_patch
+ $p->{Commit} ,$cc,
+ "$patchname$index", $author, $msg,
"Date: $commitdate\n".
"X-Dgit-Generated: $clogp->{Version} $cc\n";