summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2023-06-14 22:09:47 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2023-06-14 22:39:13 +0100
commit5f716968fec49ef4d72c911f3df28645651a5b79 (patch)
tree09fae759c8772d0c8e8648eb4a2b6b3972eed006
parent964bd1123f4c5e7b58213517c422abea4c922358 (diff)
dgit: Pass --no-source-only-changes to sbuild
Now that bookworm is released, this is now supported even by old-old-stable. Closes: #904969 Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog6
-rwxr-xr-xdgit2
2 files changed, 7 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 53ad9bb..e266a80 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -7,6 +7,12 @@ dgit (10.8~) unstable; urgency=medium
* Tests: work around git changes in 2.40 relating to commit verification.
Skipping tests involving now-uncreatable objects. Closes: #1033503.
+ * Pass --no-source-only-changes to sbuild (when building binaries).
+ Fixes operation with SOURCE_ONLY_CHANGES locally overridden.
+ (Incompatible with sbuild <0.78; to work around, say
+ dgit --sbuild!:--no-source-only-changes.).
+ [Report from Sean Whitton] Closes: #904969.
+
--
dgit (10.7) unstable; urgency=medium
diff --git a/dgit b/dgit
index 3cbf8aa..30d7629 100755
--- a/dgit
+++ b/dgit
@@ -129,7 +129,7 @@ our (@curl) = (qw(curl --proto-redir), '-all,http,https', qw(-L));
our (@dput) = qw(dput);
our (@debsign) = qw(debsign);
our (@gpg) = qw(gpg);
-our (@sbuild) = (qw(sbuild --no-source));
+our (@sbuild) = (qw(sbuild --no-source --no-source-only-changes));
our (@ssh) = 'ssh';
our (@dgit) = qw(dgit);
our (@git_debrebase) = qw(git-debrebase);