summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2024-04-11 20:14:30 +0100
committerSean Whitton <spwhitton@spwhitton.name>2024-04-13 11:05:58 +0800
commit01ad016d0954108712c4a1d621b2cc256dee54c7 (patch)
tree1ead87ead56f69b60b933e9248920d142ad56fbf
parentcdc446d6e1d8139b46ea293a0a2febaa5f250d51 (diff)
tag2upload(5): Ship in git-debpush.deb
Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--.gitignore1
-rw-r--r--Makefile7
2 files changed, 7 insertions, 1 deletions
diff --git a/.gitignore b/.gitignore
index 6e87a61..8331ca2 100644
--- a/.gitignore
+++ b/.gitignore
@@ -22,5 +22,6 @@ dgit-downstream-dsc.7
git-debrebase.1
git-debrebase.5
git-debpush.1
+tag2upload.5
substituted
.po4a.translated-only
diff --git a/Makefile b/Makefile
index e1d3236..4c2cd04 100644
--- a/Makefile
+++ b/Makefile
@@ -63,7 +63,7 @@ GDR_MAN1PAGES=git-debrebase.1
GDR_MAN5PAGES=git-debrebase.5
GDP_PROGRAMS=git-debpush
-GDP_MAN1PAGES=git-debpush.1
+GDP_MAN1PAGES=git-debpush.1 tag2upload.5
INFRA_PROGRAMS=dgit-repos-server dgit-ssh-dispatch dgit-mirror-ssh-wrap \
dgit-repos-policy-debian dgit-repos-admin-debian \
@@ -172,5 +172,10 @@ git-debpush.1: git-debpush.1.pod
--name git-debpush \
$^ $@
+tag2upload.5: tag2upload.5.pod
+ pod2man --section=5 --date="Debian Project" --center="tag2upload" \
+ --name tag2upload \
+ $^ $@
+
%.view: %
man -l $*