summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2023-02-22 14:04:27 -0700
committerSean Whitton <spwhitton@spwhitton.name>2023-02-22 14:04:27 -0700
commit5ee4728272bac1bcbdd0b1e63e820dc56a371401 (patch)
tree84d2c272f30c2febe391f9a3eeb8836778cabe22
parentf4f6af4b5054e2f25a2695e8746d772787d42233 (diff)
dgit(1), dgit-maint-merge(7): Copy-edit changes since dgit 9.16
Signed-off-by: Sean Whitton <spwhitton@spwhitton.name>
-rw-r--r--debian/changelog2
-rw-r--r--dgit-maint-merge.7.pod16
-rw-r--r--dgit.116
3 files changed, 14 insertions, 20 deletions
diff --git a/debian/changelog b/debian/changelog
index c84a7f8..656ebbe 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,6 @@
dgit (10.7~) unstable; urgency=medium
- *
+ * dgit(1), dgit-maint-merge(7): Copy-edit changes since dgit 9.16.
--
diff --git a/dgit-maint-merge.7.pod b/dgit-maint-merge.7.pod
index b60da85..07fb9a8 100644
--- a/dgit-maint-merge.7.pod
+++ b/dgit-maint-merge.7.pod
@@ -285,7 +285,7 @@ avoids introducing a new origin commit into your git history. (This
origin commit would represent the most recent non-dgit upload of the
package, but this should already be represented in your git history.)
-=head1 SOURCE PACKAGE AND GIT WORKING TREE CONFIGURATION
+=head1 SOURCE PACKAGE AND GIT CONFIGURATION
=head2 dgit configuration
@@ -298,15 +298,9 @@ a linear queue of patches to the upstream source:
=back
-This affects only this one git tree;
-your other git trees for this package (and co-maintainers)
-will need it too.
-Don't set it more globally,
-because the maintainers of any other packages
-you work on, or send patches for,
-may be offended by its effects.
-
-unpleasant NMUs
+This command should be executed in each git clone of this package, including
+your co-maintainer's. Don't set it more globally, because it is not a good
+default for working on Debian source packages in general.
=head2 debian/source/options
@@ -351,8 +345,6 @@ first upload of upstream version 1.2.3, you could use:
(If you have dgit, use `dgit clone foo`,
rather than plain `git clone`.)
-A single combined diff, containing all the changes, follows.
-
=back
=head1 BUILDING AND UPLOADING
diff --git a/dgit.1 b/dgit.1
index 4bad5aa..b9d8286 100644
--- a/dgit.1
+++ b/dgit.1
@@ -237,9 +237,11 @@ Tagging, signing and actually uploading should be left to dgit push.
\fBdgit push-source\fR [\fIsuite\fP]
Does an `upload': sends the current HEAD
to dgit-repos (as git commits),
-and to the archive (as a source package, built by dgit push-source).
+and to the archive (as a source package, built by this command).
-This is the usual way to upload to Debian.
+This is the usual way to upload to Debian. It is like saying "update the
+source code in the archive to match my git HEAD, and let the autobuilders do
+the rest."
In more detail: dgit push-source
builds a source package from HEAD.
@@ -275,12 +277,12 @@ to the archive.
The package must already
have been built ready for upload, with the .dsc and .changes
left in the parent directory. It is normally best to do the build
-with dgit too (eg with dgit sbuild): some existing build tools pass
+with dgit too (e.g. with dgit sbuild): some existing build tools pass
unhelpful options to dpkg-source et al by default, which can result in
the built source package not being identical to the git tree.
dgit will check that the .dsc corresponds exactly to the current HEAD,
-ensuring that all users whether of the dgit git view,
+ensuring that all users, whether of the dgit git view,
or of the traditional archive,
see the same source package.
.TP
@@ -321,12 +323,12 @@ public key in its keyring (but not your private key, obviously).
Configurable aliases for
.BR "dgit push-built"
and
-.BR "dgit rpush-built" ,
-which will in the future change to mean
+.BR "dgit rpush-built".
+These aliases will in the future change to mean
.BR "dgit push-source"
and
.BR "dgit rpush-source" ,
-and therefore currently generate a warning.
+and therefore they currently generate a warning.
The behaviour of dgit push is controlled by the
.B dgit.default.push-subcmd