summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2013-08-25 16:17:22 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2013-08-25 16:17:22 +0100
commit137c52ea5d2df0b07c30420697297032842407f4 (patch)
treebd7fcd136c1e155458c04c7b6f991fa6019c86cb
parenta17b1a3b36a31ac8def26e0a5aeca865873c9374 (diff)
Fix a badly open-coded copy of check_not_dirty. Closes: #720524.
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit2
2 files changed, 2 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 58de63a..cdcf9ec 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -13,6 +13,7 @@ dgit (0.11) unstable; urgency=low
and can also have more skew.)
* Better error message for use of UNRELEASED suite. Closes: #720523.
* Do not canonicalise suite more than once. Related to: #720526.
+ * Fix a badly open-coded copy of check_not_dirty. Closes: #720524.
--
diff --git a/dgit b/dgit
index 55c2b24..693aa18 100755
--- a/dgit
+++ b/dgit
@@ -953,7 +953,7 @@ sub cmd_pull {
sub cmd_push {
parseopts();
badusage "-p is not allowed with dgit push" if defined $package;
- runcmd @git, qw(diff --quiet HEAD);
+ check_not_dirty();
my $clogp = parsechangelog();
$package = getfield $clogp, 'Source';
if (@ARGV==0) {