summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2013-08-25 16:56:08 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2013-08-25 16:56:08 +0100
commitb1f6740e928e0deeb680b12a59d5b12899063320 (patch)
tree0d54df1ee6e58754ceb79aa7db06a19dff8b63b7
parent7fcdc620e03319f71e8516c6f4ab5f322c69c82b (diff)
git-build (git-buildpackage wrapper) does not bother canonicalising the suite if --git-ignore-branch is used.
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index e67bfe8..cb21861 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -19,6 +19,8 @@ dgit (0.11) unstable; urgency=low
* Fix some bugs in building (eg build-source would fail to do the quilt
fixup; the --clean check in build was wrong).
* Add missing dependency on realpath.
+ * git-build (git-buildpackage wrapper) does not bother canonicalising
+ the suite if --git-ignore-branch is used.
--
diff --git a/dgit b/dgit
index 3cb4780..892cde2 100755
--- a/dgit
+++ b/dgit
@@ -1077,7 +1077,7 @@ sub cmd_git_build {
my @cmd =
(qw(git-buildpackage -us -uc --git-no-sign-tags),
"--git-builder=@dpkgbuildpackage");
- unless (grep { m/^--git-debian-branch/ } @ARGV) {
+ unless (grep { m/^--git-debian-branch|^--git-ignore-branch/ } @ARGV) {
canonicalise_suite();
push @cmd, "--git-debian-branch=".lbranch();
}