summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-09-24 11:19:42 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-09-26 01:16:54 +0100
commit64d159f5dd06cbe512cfb534a8391d691b30ec6c (patch)
treea599864666159ee98d4a82b144dd750a0513e972
parentea6fc0f9f4d518697f7f9f65ea342a2cef569c53 (diff)
dgit: Turn gc.auto off in our hidden working tree setups
This avoids potential accidents: git gc --auto might otherwise run and do very undesirable things to the user's working tree. (I haven't been able to trigger such a situation deliberately and none has been reported, luckily...) Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit1
2 files changed, 2 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index ee5f7d0..7143fe7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -48,6 +48,7 @@ dgit (1.5~~) unstable; urgency=medium
source. Fixes bad Perl poetry syntax. Closes:#829121.
* When synthesing a commit from a .dsc from the archive, stop
internal git reset from printing a confusing message about HEAD.
+ * Turn off git gc in the private working areas.
Test suite:
* When sbuild fails, do not crash due to sed not finding the log
diff --git a/dgit b/dgit
index 39efa04..b1cb9b2 100755
--- a/dgit
+++ b/dgit
@@ -1340,6 +1340,7 @@ sub prep_ud (;$) {
sub mktree_in_ud_here () {
runcmd qw(git init -q);
+ runcmd qw(git config gc.auto 0);
rmtree('.git/objects');
symlink '../../../../objects','.git/objects' or die $!;
}