summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-11-07 02:56:08 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-11-07 02:56:10 +0000
commit6cd2df7eeec8f951c6b7971b1e1ffdce04dd633b (patch)
tree87f8be769374a3d912fafe7ff037bc67e90128db
parentf283022faa83ee21d5441aafd9c9f11be1aee6fe (diff)
Actually honour the branch name for $isuite, if we are on dgit branch
As documented in the manpage. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index c8f8155..bdc13ea 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,8 @@ dgit (2.10~) unstable; urgency=medium
build-essential. But we don't actually need build-essential.)
* When cloning a distro which has no git server, correctly leave
the user on the local dgit branch, not on `master'.
+ * Actually honour the branch name, if we are on dgit branch, to specify
+ the suite, as documented in the manpage.
--
diff --git a/dgit b/dgit
index a95629f..aa5da93 100755
--- a/dgit
+++ b/dgit
@@ -3899,7 +3899,7 @@ sub fetchpullargs () {
$package = getfield $sourcep, 'Source';
}
if (@ARGV==0) {
-# $isuite = branchsuite(); # this doesn't work because dak hates canons
+ $isuite = branchsuite();
if (!$isuite) {
my $clogp = parsechangelog();
$isuite = getfield $clogp, 'Distribution';