summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2015-08-21 17:36:25 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2015-08-21 17:36:25 +0100
commitfef73c57e195e389e6bd9f0ae6ec48a020c70c16 (patch)
tree4ea85bd943d1d8e21da68790d721b738643abce2
parentb2e8381222753378ff4d67ca7f4112b5e4d1d69d (diff)
With dgit sbuild, pass our -d before the user's arguments, so that the user can override it. Closes:#796019.
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index f9308c5..e09cfbb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -18,6 +18,8 @@ dgit (1.4~~) UNRELEASED; urgency=low
* Cope properly with `3.0 (quilt)' with single-debian-patch.
Closes:#796016. (Still does not work with wheezy's dpkg-source, so
no test case yet.)
+ * With dgit sbuild, pass our -d before the user's arguments, so that
+ the user can override it. Closes:#796019.
--
diff --git a/dgit b/dgit
index 7b62a66..7b447de 100755
--- a/dgit
+++ b/dgit
@@ -3139,7 +3139,7 @@ sub cmd_sbuild {
unlink $cf or fail "remove $cf: $!";
}
}
- runcmd_ordryrun_local @sbuild, @ARGV, qw(-d), $isuite, $dscfn;
+ runcmd_ordryrun_local @sbuild, qw(-d), $isuite, @ARGV, $dscfn;
my @changesfiles = glob $pat;
@changesfiles = sort {
($b =~ m/_source\.changes$/ <=> $a =~ m/_source\.changes$/)