summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-27 20:22:10 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-30 19:50:48 +0000
commit2c3427f71978357151e84611d967c1650aa814dc (patch)
treebfeb4a12c7236a2675772b46b4c006cb010d43b5
parentcc0686845b8db87998cfe937014e0f3d2c24b03e (diff)
Test suite: Explicitly configure user.name and user.email
So that tests work when environment doesn't have defaults. Closes:#842279 (I hope). Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog3
-rw-r--r--tests/lib-core2
2 files changed, 5 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index bcd50b0..7497dce 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,9 @@ dgit (2.9~) unstable; urgency=low
so user never needs [--ch:]-sa or [--ch:]-sd. Closes:#829116.
* Properly look for .origs etc. in .., fetching them less often.
* New import-dsc feature.
+ * Test suite: Explicitly configure user.name and user.email, so
+ that tests work when environment doesn't have defaults.
+ Closes:#842279 (I hope).
--
diff --git a/tests/lib-core b/tests/lib-core
index 056a1bc..7ed2761 100644
--- a/tests/lib-core
+++ b/tests/lib-core
@@ -20,6 +20,8 @@ t-set-using-tmp () {
export DGIT_TEST_DUMMY_DIR=$tmp
export DGIT_TEST_TMP=$tmp
export GNUPGHOME=$tmp/nonexistent
+ git config --global user.email 'dgit-test@debian.example.net'
+ git config --global user.name 'dgit test git user'
}
t-filter-out-git-hyphen-dir () {