summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2013-08-25 16:13:36 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2013-08-25 16:14:59 +0100
commita17b1a3b36a31ac8def26e0a5aeca865873c9374 (patch)
tree61a55b67003a3ee0e5a9afdf2d2e078dc484839e
parent7c379b92923ec62699b0943831c9085c2e8e1821 (diff)
Better error message for use of UNRELEASED suite. Closes: #720523.
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
2 files changed, 4 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 7261108..58de63a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -11,6 +11,8 @@ dgit (0.11) unstable; urgency=low
* Use "ftp.debian.org" not "http.debian.net" as the default Debian
archive. (http.debian.net tends to defeat certain kinds of cacheing,
and can also have more skew.)
+ * Better error message for use of UNRELEASED suite. Closes: #720523.
+ * Do not canonicalise suite more than once. Related to: #720526.
--
diff --git a/dgit b/dgit
index 77a9bb6..55c2b24 100755
--- a/dgit
+++ b/dgit
@@ -415,6 +415,8 @@ sub canonicalise_suite_madison ($$) {
}
sub canonicalise_suite () {
+ return if defined $csuite;
+ fail "cannot operate on $isuite suite" if $isuite eq 'UNRELEASED';
$csuite = archive_query('canonicalise_suite');
if ($isuite ne $csuite) {
# madison canonicalises for us