summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2013-10-23 13:01:09 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2013-10-23 13:01:09 +0100
commit13b1e20cfd307469a6a53ad5798476f18176870a (patch)
treeda10ec0674424fafd2841b150c56da2d7615f24d
parent82e96b6ad7d79f252e5343407cf2f718d3e03918 (diff)
Minor fix to remote functionality:
* Improve debug output at completion.
-rw-r--r--debian/changelog7
-rwxr-xr-xdgit3
2 files changed, 9 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index ae985a5..e3adde5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+dgit (0.17~experimental3) experimental; urgency=low
+
+ Minor fix to remote functionality:
+ * Improve debug output at completion.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Wed, 23 Oct 2013 13:00:50 +0100
+
dgit (0.17~experimental2) experimental; urgency=low
* When generating git tags, quote the (uncanonicalised) changelog's
diff --git a/dgit b/dgit
index 5308386..37a6111 100755
--- a/dgit
+++ b/dgit
@@ -1515,12 +1515,13 @@ sub i_resp_progress ($) {
sub i_resp_complete {
my $pid = $i_child_pid;
$i_child_pid = undef; # prevents killing some other process with same pid
- printdebug "waiting for remote child $pid...";
+ printdebug "waiting for remote child $pid...\n";
my $got = waitpid $pid, 0;
die $! unless $got == $pid;
die "remote child failed $?" if $?;
i_cleanup();
+ printdebug "all done\n";
exit 0;
}