summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2013-09-26 01:47:47 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2013-09-26 01:47:47 +0100
commit2d8535ab6b3445dc678191019b71850c4fa8f04f (patch)
tree913016169896d327da64f7e2c627ed3385cc024c
parentf8607d8ff99642d610d2bc338eb831aae4baba2b (diff)
Command execution reports from --dry-run go to stderr.
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit2
2 files changed, 2 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index bf459a9..4820110 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ dgit (0.16~experimental2) experimental; urgency=low
* WIP remote functionality. Untested, do not use.
* push actually takes an optional suite, like it says in the synopsis.
+ * Command execution reports from --dry-run go to stderr.
--
diff --git a/dgit b/dgit
index 357ccc3..bee98b9 100755
--- a/dgit
+++ b/dgit
@@ -204,7 +204,7 @@ sub cmdoutput {
}
sub dryrun_report {
- printcmd(\*STDOUT,"#",@_);
+ printcmd(\*STDERR,"#",@_);
}
sub runcmd_ordryrun {