summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2013-10-21 15:32:12 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2013-10-21 15:32:12 +0100
commitaa031dd019a9b1d561aafac0ddb04ad5b3ae25ee (patch)
tree2c5cf9109437ca852274589146e8be2e462247a9
parent13134e3159841328c681a416e6dc220e1f704e9f (diff)
fix printcmd and shellquote
-rw-r--r--debian/changelog6
-rwxr-xr-xdgit4
2 files changed, 8 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index f08a073..883b855 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+dgit (0.16~experimental3) experimental; urgency=low
+
+ * Minor fixes arising from changes since 0.15.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Mon, 21 Oct 2013 15:31:59 +0100
+
dgit (0.16~experimental2) experimental; urgency=low
* WIP remote functionality. Untested, do not use.
diff --git a/dgit b/dgit
index 0c024c9..2f4ce48 100755
--- a/dgit
+++ b/dgit
@@ -289,13 +289,13 @@ sub shellquote {
push @out, $_;
}
}
- return join '', @out;
+ return join ' ', @out;
}
sub printcmd {
my $fh = shift @_;
my $intro = shift @_;
- print $fh $intro or die $!;
+ print $fh $intro," " or die $!;
print $fh shellquote @_ or die $!;
print $fh "\n" or die $!;
}