summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2015-06-30 21:02:38 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2015-06-30 21:02:38 +0100
commit02664d80306d561e03cde2108a6dc5ee7626d6a3 (patch)
tree4377d3c3db6fac348c1b9fd31f858804021ac45f
parentfd8f387167425d0c9da7bce0ffc460a57d0ceced (diff)
Provide example workflow for dgit rpush. Closes:#763334.
-rw-r--r--debian/changelog2
-rw-r--r--dgit.112
2 files changed, 13 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index a6353e1..7969a61 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -75,6 +75,8 @@ dgit (0.23~) unstable; urgency=low
* Detect and bomb out on vendor-specific `3.0 (quilt)' patch series.
+ * Provide example workflow for dgit rpush. Closes:#763334.
+
--
dgit (0.22.1) unstable; urgency=high
diff --git a/dgit.1 b/dgit.1
index 72b16a0..a33dcb7 100644
--- a/dgit.1
+++ b/dgit.1
@@ -167,7 +167,17 @@ Pushes the contents of the specified directory on a remote machine.
This is like running dgit push on build-host with build-dir as the
current directory; however, signing operations are done on the
invoking host. This allows you to do a push when the system which has
-the source code and the build outputs has no access to the key.
+the source code and the build outputs has no access to the key:
+
+1. Clone on build host (dgit clone)
+.br
+2. Edit code on build host (edit, git commit)
+.br
+3. Build package on build host (dgit build)
+.br
+4. Test package on build host or elsewhere (dpkg -i, test)
+.br
+5. Upload by invoking dgit rpush on host with your GPG key.
However, the build-host must be able to ssh to the dgit repos. If
this is not already the case, you must organise it separately, for