summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2013-08-17 17:12:32 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2013-08-17 17:12:32 +0100
commit916da427127794108f20f80d5018493002b81876 (patch)
treee3e223b1d447a0a2c3581935034c1f44ec975e9a
parentf5bb5d94a3c7d661b7f0253969e1490ffc994490 (diff)
fix quilt fixup
-rwxr-xr-xdgit3
-rw-r--r--dgit.15
2 files changed, 6 insertions, 2 deletions
diff --git a/dgit b/dgit
index 7f68b09..487c1be 100755
--- a/dgit
+++ b/dgit
@@ -559,7 +559,7 @@ sub commit_quilty_patch () {
my $output = cmdoutput @git, qw(status --porcelain);
my $vsn = $dsc->{Version};
my %fixups = map {$_=>1}
- (".pc/debian-changes-$vsn/","debian/patches/debian-changes-2.8-5");
+ (".pc/debian-changes-$vsn/","debian/patches/debian-changes-$vsn");
my @files;
foreach my $l (split /\n/, $output) {
next unless $l =~ s/^\?\? //;
@@ -584,6 +584,7 @@ sub dopush () {
$dsc = parsecontrol("../$dscfn");
print DEBUG "format $dsc->{Format}\n";
if ($dsc->{Format} eq '3.0 (quilt)') {
+ print "Format \`$dsc->{Format}', urgh\n";
commit_quilty_patch();
}
check_not_dirty();
diff --git a/dgit.1 b/dgit.1
index 37601e7..8d4d201 100644
--- a/dgit.1
+++ b/dgit.1
@@ -52,7 +52,10 @@ Tagging and signing should be left to dgit push.
does an `upload', pushing the current HEAD to the archive (as a source
package) and to dgit-repos (as git commits). This also involves
making a signed git tag, and signing the files to be uploaded to the
-archive.
+archive. (For a format `3.0 (quilt)' source package, dgit push
+may also have to make a commit on your current branch to contain
+quilt metadata. It will do this automatically.)
+.BR "debian/rules clean" .
.SH WORKFLOW - SIMPLE
It is always possible with dgit to clone or fetch a package, make
changes in git (using git-commit) on the suite branch