summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2013-08-24 18:12:52 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2013-08-24 18:12:52 +0100
commit10eb7774037c99711c6f8ca70b3ccfce7215b08e (patch)
treeb1e4b905a5d3439c4fdfaaf0870e20fea7a76a3a
parent7cc77250e68bee4283757b7516e0a70f77904086 (diff)
Better error when source package contains .git. Closes: #720555.
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit2
2 files changed, 2 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index aa06a7f..ac43643 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,7 @@ dgit (0.9) unstable; urgency=low
* New cleaning arrangements.
* More comprehensive workaround for `3.0 (quilt)'.
* In push, double-check the .changes against the changelog.
+ * Better error when source package contains .git. Closes: #720555.
--
diff --git a/dgit b/dgit
index 2d47dbf..645528f 100755
--- a/dgit
+++ b/dgit
@@ -488,7 +488,7 @@ sub mktree_in_ud_from_only_subdir () {
$dirs[0] =~ m#^([^/]+)/\.$# or die;
my $dir = $1;
chdir $dir or die "$dir $!";
- die if stat '.git';
+ fail "source package contains .git directory" if stat '.git';
die $! unless $!==&ENOENT;
runcmd qw(git init -q);
rmtree('.git/objects');