summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2015-07-26 21:37:43 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2015-07-26 22:54:29 +0100
commitd33fa1545969c40c257a02c3a442b1e47d291b16 (patch)
treef99f4a54ee3b4f04e3dacd63f4b32c888bd4b563
parentb1772b364e75b32c413db7060a0adf8b124c84db (diff)
Make configuration able to prevent dpkg-mergechangelogs setup.
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit7
-rw-r--r--dgit.15
3 files changed, 11 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 1595f71..8d3cca9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -42,6 +42,7 @@ dgit (1.1~~) unstable; urgency=low
* Slurp in entire git config, for better performance.
* With -DDDD, print out all gitcfg references (copious!)
* Fix a debug message in the obsolete sshpsql archive access driver.
+ * Make configuration able to prevent dpkg-mergechangelogs setup.
--
diff --git a/dgit b/dgit
index ae96531..a935cbf 100755
--- a/dgit
+++ b/dgit
@@ -1638,7 +1638,10 @@ sub set_local_git_config ($$) {
runcmd @git, qw(config), $k, $v;
}
-sub setup_mergechangelogs () {
+sub setup_mergechangelogs (;$) {
+ my ($always) = @_;
+ return unless $always || access_cfg_bool(1, 'setup-mergechangelogs');
+
my $driver = 'dpkg-mergechangelogs';
my $cb = "merge.$driver";
my $attrs = '.git/info/attributes';
@@ -3021,7 +3024,7 @@ sub cmd_clone_dgit_repos_server {
sub cmd_setup_mergechangelogs {
badusage "no arguments allowed to dgit setup-mergechangelogs" if @ARGV;
- setup_mergechangelogs();
+ setup_mergechangelogs(1);
}
#---------- argument parsing and main program ----------
diff --git a/dgit.1 b/dgit.1
index 1507d43..2b626a1 100644
--- a/dgit.1
+++ b/dgit.1
@@ -634,6 +634,11 @@ Not relevant for Debian.
.BI dgit-distro. distro .upload-host
Might be useful if you have an intermediate queue server.
.TP
+.BI dgit-distro. distro .setup-mergechangelogs
+Whether to setup a merge driver which uses dpkg-mergechangelogs for
+debian/changelog. True by default. Ignored for dgit
+setup-mergechangelogs, which does it anyway.
+.TP
.BI dgit-distro. distro .cmd- cmd
Program to use instead of
.IR cmd .