summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-10 13:43:10 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-10 14:06:39 +0000
commit3fb35c205e2ee6e020c2e0173eb2d9c48a099617 (patch)
treed1670665295021328dcd5d9f5a34d76c9929023e
parent47f38d740a6e922805acbf20a1606d27fb559c58 (diff)
dgit: After downloading .debian.* files, save them in `..', too
Ie do this not just for .origs. We don't want the user needlessly re-downloading them on each fetch. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit8
2 files changed, 5 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 7154fda..bc75930 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,8 @@ dgit (3.1~) unstable; urgency=medium
Bugfixes:
* dgit import-dsc: Do not crash with undefined $isuite. Closes:#850781.
* dgit: Do not nedlessly re-fetch the rewrite map.
+ * dgit: After downloading .debian.* files, save them in `..', too
+ (ie do this not just for .origs).
Test suite:
* Add test for import-dsc with default distro. (Detects #850781.)
diff --git a/dgit b/dgit
index eee1806..eae6f24 100755
--- a/dgit
+++ b/dgit
@@ -2083,11 +2083,9 @@ sub generate_commits_from_dsc () {
complete_file_from_dsc('.', $fi)
or next;
- if (is_orig_file_in_dsc($f, \@dfi)) {
- link $f, "../../../../$f"
- or $!==&EEXIST
- or die "$f $!";
- }
+ link $f, "../../../../$f"
+ or $!==&EEXIST
+ or die "$f $!";
}
# We unpack and record the orig tarballs first, so that we only